We are continuing to monitor for any further issues.
Posted Apr 02, 2025 - 15:43 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2025 - 15:42 CEST
Identified
Dear Customer,
We currently experience issues with our ticketing system. During this time, you may have difficulties while logging or updating support tickets.
We apologize for the inconvenience and will share an update once we have more information. If you need urgent assistance you can always contact us by e-mail or phone.